Why won’t my digital files work in iMovie?

Great question!

There are some versions of iMovie that are compatible with MP4 files and some that are not.

Newer versions of iMovie have added support for working with MP4 files, specifically with the particular video codecs we use to encode your digital files. 

To guarantee support for the MP4 files we create, we recommend using iMovie version 10.1.8. If you are running a version older than that, you may experience difficulty importing the video files into iMovie.

iMovie is bundled with macOS Sierra 10.12 for free in the App Store. For best results, you should always make sure your software is always as up to date as possible.

If you are unsure of whether your computer can make the cut to run this version of iMovie, you can log into Apple’s App Store to find out! The update to macOS Sierra 10.12 is a free upgrade through the App Store for the following computers, given their specifications match the ones here, provided by Apple:

macOS Sierra 10.12 requires at least 2 GB of RAM and 8 GB of storage space and:

  • iMac: late 2009 or newer.
  • MacBook and MacBook 12-inch: late 2009 or newer.
  • MacBook Pro: mid-2010 or newer.
  • MacBook Air: late 2010 or newer.
  • Mac Mini: mid-2010 or newer.
  • Mac Pro: mid-2010 or newer.
Can’t find your answer in our support center? Contact us directly.